Digital Camera Software
NameExif 1.4
I have problems using NE 1.4. Here is the error message I get:
** Script Error: Out of range or past end
** Where: build-tree
** Near: any [slash <> last b/2 remove back tail b/2]
** Press enter to quit...

when Namexif.exe is NOT residing on the desktop and I ask for a directory. The same occurs if I try to acces to the web page from the splash screen:

** Script Error: External process failed: Le nom de répertoire est incorrect.
** Where: func [face value][browse ""]
** Near: browse ""
** Press enter to quit...

What can I (you) do ?
Welcome Mimi!

First of all: Thanks for taking the time to report an issue. This will help us to improve this tool.

Now, the bad part is that I can't reproduce your issue

Can you tell if there is something special with your environment? Like multiple drives, system not installed on C:, running Vista, ... ?

In the meantime, I will attempt a fix based on error messages you've reported. I keep you posted. If you wish, you can leave us your email address on the about page so I can send you an email when a fix is ready.

Since I posted, I have just restarted the system 10 minutes ago (I most usually go into deep hibernation), and the problem seems to have disappeared. So, thank you, but the problem is no longer an issue.

Hi again.

I was in error : the bug still holds if I try to execute when the .exe is in a sub-directory in the D: drive (which is a partition of the disk). About the environment : Win XP up to date, system on drive C. If I put the executable directly on the C drive, all seems OK. Same if the executable is in the c:\program files.

Finally, I think that the bug depends on the depth the .exe lies in a primary partition, C or D. The funny thing is that it executes OK when sitting in the desktop, which is several levels deep on the C disk...

Will try to reproduce your issue on a similar environment.
Error messages you provided will help anyway.
I'll post here when an update is available!
Hopefully you can use it if it is on your Desktop folder!
I get the same error messages when I run the program right from install. When I run it from the installed directory, I do not get those error messages
I'm getting the same error. I have 3 hard drives with system on C:. Image files are on D:, but I never get far enough to indicate that.
Problem only occoured when I launched the app from the downloads window of Firefox. When I go to the directory where the exe exists, runs fine.

Some sort of effective "pwd" problem?
You know what?
I'm glad that I can reproduce the issue when launching from firefox downloads, this will easy to fix now.
Get ready for Namexif 1.5 soon
A great software. Thank you.

This is to report the same problem as reported before from some people: I can´t use the directory feature:
** Script Error: Out of range or past end
** Where: build-tree
** Near: any [slash <> last b/2 remove back tail b/2]
** Press enter to quit...

Curiousely, I can´t either access to your web from the link:

** Script Error: External process failed: El nombre del directorio no es válido.

** Where: func [face value][browse ""]
** Near: browse ""
** Press enter to quit...

I'm sure that you are going to find out the solution
Welcome Pere!

Thanks for reporting your issues, we'll work on solutions

For now, httphotos consumes most of our time and the next Namexif update may only be around May 2008.
Meanwhile, you can play with httphotos!

Login required to Post. Click Login button to proceed.