Digital Camera Software
Namexif 1.7
Namexif 1.7 is out!

It features full flexibility on format to rename by providing a simple field for customization by user.
The user format is of course remembered after each use.
It also fixes the subdirectory checkbox selection for inclusion or not.

Looks interesting - does this also solve the mulitple filename extension that I requested?
I'll make a version for you doing what you requested.
Brilliant - I will look out for that once you got it ready. Think it might benefit others as well. Thanks.
Still waiting is it going to be soon?
Sorry for the wait Alan, I'm pretty well loaded these days, will do my best to release this customized version!
Thats ok - whenever you get a chance - I hope the special release will be based on what v1.7 does now - that would be super cool and I suspect satisfy most peoples needs in that area. I work around the shortcomings now - but look forward to your latest release with much anticipation.
Just installed V1.7 and I like the custom naming feature as I've chosen a format that makes reading date and time so much easier, well done. Now just waiting for a b c filenaming for multiples feature . . . . .
Please try this one:

It adds a,b,c... instead of 1,2,3... and no dash.
Now, it will probably crash if you go beyond z! I didn't address this point.
Hope it will solve your issue.
Thanks Greg - sent seperate email - no worries on reaching z - I don't know of a camera on the market that can take in excess of 26 frames per second - but if one day they do then I'm sure the rich owner will be only too happy to commission you for a special!

Hope this will be the standard way of resolving multiple pics with the same timestamp.

Thanks for the program! Its very useful and easy to handle and now even customizable.
I also wanted to mention some little bugs I found:
1. If in the custom-mode the last added character is a space, the "do not use the characters:*?<>]:"-error is shown. An error where I needed some time to get it, why it was shown.
2. If more than 1,73 GB (or maybe more than 690 fotos) are added, nothing happens/ nothing will be added to the program without any comment.
3. While the renaming-prozess the program shows: "please wait, work in progress", which switches to "Work completed.". When the user now hits: "again?" and adds other fotos, the program still shows: "work completed" the whole time while renaming.
Best wishes from Berlin,
Thanks for the feedback Yanez
I'll take them all into account for next version.
Thanks for the program itīs super helpfull however I have a question, I need to edit the name but else a sequency of numbers like xxx-xxx-xxx-#1, xxx-xxx-xxx-#2... but I have a bunch of pics that are from different days and every day the counters returns to 1, how can I maintain the sequency?

Appreciate your help
Hi Chanch,
This is very specific... Not sure how to help here.
Hey, what's going on with this error: Incorrect filename. Do not use \/:*?"<>|
Custom Format worked well, unless I typed space at end.
Now CF won't work at all, whatever I set up there o_O
Field has always yellow backlit and program refuses renaming.
One of the big strengths of this tool is its simplicity. I have a suggestion to make it even simpler to use: support drag-and-drop of files into the main window, rather than having to navigate through possibly complex folder structures to find the desired images.
Hi GreG:
Am getting same character errors as Yanez and boom. Using Windows 10. It worked fine last month (Feb 2017) but now will not convert. Says "cannot rename... (JPEG)". I noticed that the Select Folder adds some ' to the directory. For example it says: C:\Users'\Owner\Pictures'\111 Download Area. When I open the directory, an example path uses forward slashes without ' : /C/Users/Owner/Pictures/111 Download Area/P1040808.JPG Hope these details help you create a solution.
I am assuming Namexif 1.7 is no longer supported. Can I have a recommendation for a substitute? I have PaintShop Pro X6 if that's of any use for renaming.
Installed Bitdefender 2018 tonight on my machine and a warning occurred under their "Safe Files" protection feature. That notification did not occur under Bitdefender 2017 so I did not know it was blocking the file name change. I allowed it access and it ran fine.

However, if I chose a custom file format - such as YYYY-MM-DD (as I had previously been able to do) it would not convert properly. And the space between DD and hh was previously workable. Maybe something to do with MM & mm?

Insofar as my Aug 27th comment, that machine is using McAfee so not sure how to solve that one.
Should be entered as: (YYYY)-(MM)-(DD) (hh).(mm).(ss)
Thanks for the feedback Steve, this can help others as well.

Login required to Post. Click Login button to proceed.